Noticias y novedades

Android P bloqueará la instalación de apps demasiado antiguas

Android P parece que bloqueará la instalación de aplicaciones que se dirijan a versiones anteriores a Android 4.2 Jelly Bean.

19 marzo, 2018 08:43

En los sistemas operativos actuales hay algo que damos por sentado en casi todos los aspectos: la retrocompatibilidad.

Con la salvedad de Windows y sus versiones móviles, no las de escritorio, presuponemos que cualquier aplicación va a funcionar en las versiones futuras de los sistemas operativos, seguramente porque los fabricantes se han preocupado de que así sea, para mantener cierta estabilidad en el uso de sus dispositivos.

Sin embargo, esto implica que los desarrolladores no están incentivados a actualizar sus aplicaciones ya que serán los desarrolladores de los sistemas los que al final acaben haciéndolas compatibles.

En Android hemos visto cosas semejantes, aplicaciones muy antiguas que funcionan en móviles nuevos sin mayores problemas, pero parece que Google ha decidido echar el freno.

Android P no instalará apps de Android 4.1 o versiones anteriores

En la documentación del código de Android P que se ha liberado con la Developer Preview 1 que estamos probamos se ha visto una nueva orden que haría que el sistema impidiera la instalación de aplicaciones demasiado antiguas. No hablamos de las que tienen uno o dos años, sino de apps que se dejaron de actualizar en Android 4.2 Jelly Bean.

Este código, Build.Version.MIN_SUPPORTED_TARGET_SDK_INT  comprueba si la aplicación tiene una API lo suficientemente actualizada. Si es así permite la instalación en el sistema pero sino lo impide y sugiere que nos pongamos en contacto con el desarrollador. Podemos ver cómo es el proceso en el video publicado por Android Police y en el que se usa el emulador para intentar instalar una app demasiado antigua:

No obstante esto es algo que se ha comprobado en Android P DP1 y que podría cambiar en la versión final si Google, por el motivo que sea, decide que es un movimiento demasiado agresivo.

Menos del 3% de móviles afectados

Si finalmente viéramos una acción de este tipo las aplicaciones deberían usar APIS más actuales lo que haría que no se pudieran instalar en los móviles más antiguos, o al menos no desde la Google Play Store.

Pero si nos paramos a mirar las últimas cifras de versiones de Android en los smartphones que se usan actualmente vemos como menos del 3% de los móviles actuales usan una versión inferior a la que permitiría Android P.

Evidentemente esa limitación iría subiendo en futuras versiones de manera que los desarrolladores deberían ir modificando el API más bajo al que daría soporte para mitigar los problemas de fragmentación y sobre todo para poder usar las novedades de esas APIs que quizás obvien para dar cobertura a móviles muy antiguos.