Noticias y novedades

Samsung, Wiko y otros dispositivos tienen problemas de compatibilidad con apps Material Design

24 noviembre, 2014 09:40

Con la llegada de Android 5.0 Lollipop y su nueva interfaz Material Design, cada vez son más los desarrolladores que se animan a actualizar sus aplicaciones a las nuevas líneas de diseño indicadas por Google. Material Design no se limitará sólo a aplicaciones, ya que la idea es que pueda estar presente también en pantallas de todos los tamaños, ya sea aplicado en una web o incluso como un sistema operativo propio.

A todos nos alegra ver cómo las aplicaciones van actualizándose con el característico estilo de Material Design, pero ahora conocemos que algunos usuarios estarían teniendo problemas con ellas. En concreto, varios dispositivos Samsung, Wiko, QMobile y MyPhone utilizan versiones antiguas de las librerías de soporte en el framework o classpath, de forma que al intentar ejecutar las nuevas versiones de las aplicaciones adaptadas dan errores y se cierran.

La mayoría de dispositivos afectados son aquellos que funcionan con Android 4.2.2 y, aunque en principio se atribuía a TouchWiz (por la mayor distribución de terminales en todo el planeta) más tarde se ha conocido que otras marcas también tienen los mismos fallos.

La solución del problema pasa por una actualización general de Samsung y Wiko a sus viejos dispositivos, pero de momento el conocido desarrollador Koushik Dutta ha ofrecido una solución que los mismos desarrolladores de las aplicaciones afectadas pueden aplicar: renombrar las librerías afectadas con la ayuda de ProGuard.

Samsung es el fabricante más afectado por el problema y, seguramente, estará actualmente totalmente centrado en la actualización a Android 5.0 Lollipop para sus últimos terminales, como el Note 3, 4, y demás miembros de la familia Galaxy, ¿dedicará recursos para ofrecer una OTA que solucione el fallo de compatibilidad?. Y tú, ¿has notado estos fallos?.

Más información y solución | Koushik Dutta